Instalacja Kadu 0.5 na Dapperze

Mało to odkrywcza notka, ale dzisiaj w końcu zrobiłem to co chciałem już zrobić wcześniej, a mianowicie zainstalowanie nowej wersji Kadu.

O dziwo w oficjalnych repozytoriach kadu.net nie ma wersji 0.5 dla Ubuntu Dapper Drake, także trzeba było kombinować. Właściwie odpowiedź była na forum kadu, ale jeśli ktoś jest leniwy to może skorzysta z tej notki :)

A więc do dzieła!
Sposoby są dwa, dodanie nowych repozytoriów lub ściągnięcie samej paczki. Dla zainteresowanych oto są repozytoria:

deb http://83.13.105.54/~pgal/ubuntu dapper main
deb-src http://83.13.105.54/~pgal/ubuntu dapper main

Po ich dodaniu należy jeszcze pobrać klucz GPG:

sudo gpg –keyserver “hkp://subkeys.pgp.net” –recv-keys 7D158AC2
sudo apt-key add /root/.gnupg/pubring.gpg

Nie wiem dlaczego, ale system nie dodał tych kluczy pokazał się taki error:

gpg: WARNING: unsafe ownership on configuration file `/home/radmen/.gnupg/gpg.conf’
gpg: external program calls are disabled due to unsafe options file permissions
gpg: keyserver communications error: general error
gpg: keyserver receive failed: general error

Także postanowiłem sobie po prostu pobrać nową paczkę.
Paczki można pobrać bezpośrednio z tej strony.
Ściągamy oczywiście paczkę “kadu_0.5.0-0ubuntu1_i386.deb” oraz “kadu-tabs_0.5.0-0ubuntu1_i386.deb”.
Nowe Kadu instalujemy poleceniem:

sudo dpkg -i ./kadu_0.5.0-0ubuntu1_i386.deb

Oraz potem instalujemy drugą paczkę poleceniem

sudo dpkg -i ./kadu-tabs_0.5.0-0ubuntu1_i386.deb

Odpalamy nowe Kadu. Następuje proces migracji, którego nie trzeba opisywać :)
Po migracji należy zrestartować kadu.
Jeśli chcesz mieć jedno okno rozmowy, z kilkoma kartami (podobnie jak w FF) to musisz załadować moduł “tabs” oraz w menu konfiguracja wybieramy zakładkę “Rozmowa” i tam na dole jest taki “dział” karty. Zaznaczamy “Domyślnie używaj kart”.
To wszystko :)

6 Responses to “Instalacja Kadu 0.5 na Dapperze”

  1. vandut February 23, 2007 at 8:32 pm #

    Nie jestem do końca pewien jaka jest różnica między Twoim wpisem, a tym: http://www.kadu.net/w/Pobierz:Ubuntu

    I tak, paczek z Kadu nie ma w repozytoriach Debiana, ani Ubuntu, natomiast słyszałem, że są prowadzone prace i coś idzie w dobrą stronę ;]

  2. radmen February 23, 2007 at 8:32 pm #

    Tak, na wiki Kadu jest dane tylko oficjalne repo. A z niego najnowszą wersją Kadu jaką miałem była ta opatrzona numerkie 0.4.3 także różnica jest spora :)
    Nie wiem jak sprawa wygląda z Edgyt Eft, możliwe, że repo dla niego jest już aktualne..

  3. D4rky February 23, 2007 at 8:32 pm #

    A nie Kadu 0.5 ? :>

  4. radmen February 23, 2007 at 8:32 pm #

    O kurna… racja :D

  5. ludwikc February 23, 2007 at 8:32 pm #

    dodaj kod do siebie zamiast do roota
    sudo apt-key add /home/radmen/.gnupg/pubring.gpg

  6. radmen February 23, 2007 at 8:32 pm #

    Ludwikc: zobaczę później :)