Gdyby irssi nie działało w Archu

Nie wiem dlaczego, ale Irssi instalowane z binarki nie działało. Nie było żadnych komunikatów błędu, nic. Niestety paczka z AUR nie udało mi się skompilować własnej paczki z powodu starej wersji pakietu perl.

Co ciekawe, wymagana wersja perla jest cały czas w repo testing, dlatego podarowałem sobie jego instalację. Niestety brak Irssi bardzo mnie bolał i koniecznie chciałem je mieć. Okazuje się, że drobna modyfikacja PKGBUILDa pomogła.

Jeśli masz ten sam problem ściągnij ten PKGBUILD, a później w konsoli:

makepkg
# pacman -A irssi-0.8.12-3-i686.pkg.tar.gz

4 Responses to “Gdyby irssi nie działało w Archu”

  1. neaf February 28, 2008 at 4:33 pm #

    Coś musi być nie halo u Ciebie, bo mi działa bez problemu :) Poza tym, są ludzie niekorzystający z yaourt’a? :D

  2. radmen February 28, 2008 at 4:33 pm #

    yaourt – nie nie korzystam. Poza tym podczas instalacji typu „pacman -S irssi” powinno wywalić komunikaty jeśli coś nie tak, co nie ?

  3. avalan February 28, 2008 at 4:33 pm #

    Tak to jest jak się miesza testing z innymi. Używaj core/extra i będzie spokój :P

  4. radmen February 28, 2008 at 4:33 pm #

    Avalan: nie mam testing dodane. Tylko core/extra/community